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Starting Mosaic
Although there are thousands of Mosaic sites on the Internet that you can explore, you 
may not know where to start.    Mosaic comes pre-configured with a home page.    This is 
done so that you have a place to start looking for other WWW resources.    
When you start Mosaic, it will automatically connect you to the pre-configured home page.
From there, you can begin browsing the Internet and begin connecting to other home 
pages.    As you become an experienced Mosaic user, you'll be able to build a library of 
home pages that you like, using Mosaic's "hotlist" feature.
You can start Mosaic by clicking on the Mosaic icon.    Mosaic will immediately start 
connecting you to a home page.    (You will see the orbit around the globe icon in the 
upper right hand corner of the Mosaic console move as the home page is retrieved.)
Once you finish connecting to a home page, you can immediately begin browsing with 
Mosaic.
Note: You can easily define your own home page to automatically connect to on startup. 

Use the Configuration option in the Options menu to set up a default home page.

See
The Mosaic Console
Browsing with Mosaic 



Browsing with Mosaic
World Wide Web uses hyperlinks (also referred to as anchors or hot spots) to allow you
to jump to other resources.    Hyperlinks are indicated by blue, underlined text, or by 
graphics surrounded by a blue border (you can change the color that is used).    Another 
way to tell that you are on a hyperlink is to highlight the text or graphic with your mouse.   
The mouse will turn into a pointing hand.
You can then click on a hyperlink to connect to another Mosaic document.    The new 
document will be opened (you will see the globe icon in the upper right hand corner of 
your Mosaic Console begin to move).    If at any time you need to stop loading in a 
document, you can click the Stop button or choose Cancel Current Task from the 
Navigate menu.
You can continue to browse through Mosaic documents by simply clicking on the 
hyperlinks you find in the document.    You can also travel through Mosaic documents you 
encounter using the methods listed below.

See
Back/Forward 
Document Title/Document URL 
History 
Home 
Reload 
Using the Quick Menu



Back/Forward
You can click on the Back button (the third button on the Toolbar) to move back to the last
document you viewed.    The Forward button (the fourth button on the Toolbar) can move 
you forward after you have moved back.    You can also type B for Back or F for Forward, 
or choose Back or Forward from the Navigate menu.



Document Title/Document URL
The Document Title: and Document URL: drop-down lists, under the Toolbar, contain a 
listing of the last several documents you've accessed in this session.    The lists are 
identical, but one shows the title of the document and the other shows that document's 
URL (http://www.bakerstreet.com).    You can go back to any of the displayed documents 
by choosing its title or URL from the lists.



History
The <History> dialog, accessed by clicking History in the Navigate menu, allows you to 
access documents you have already accessed in this session; these documents are 
displayed in a hierarchical tree structure.    
Select the document you want to go back to, and click on the Load button.



Home
At any time, you can click the Home button on the Toolbar, or choose Home from the 
Navigate menu to return to the document defined as your Home Page.    When you start 
using Mosaic, a home page is already defined as your home page; you can set up a new 
home page (or set Mosaic to start without opening a home page) using Configuration in 
the Options menu.



Reload
You can reload the current Mosaic document at any time by clicking the Reload button or 
choosing Reload from the Navigate menu.    You might want to do this if the document 
did not load properly.



Using the Quick Menu
Mosaic features an easy to use menu that can help you easily access load, save, and get 
information about a document.
Mosaic’s Quick Menu is accessed using the right mouse button.    With your mouse pointer 
over a hyperlink, click the Right mouse button.    The Quick Menu appears.
The Quick Menu will be different depending on whether you have selected a regular 
hyperlink, an image, or an image that also leads to a hyperlink.    If you selected a regular 
hyperlink, the Document options below will display.    If you selected an image, the Image 
options below will display.    If you selected an image that also leads to a hyperlink, you 
will see all the listed options, since the object is treated as both an image and a hyperlink.

The Quick Menu Options are as follows:
Document Options
Load Document Loads the document that is pointed to by the hyperlink.    Choosing 

this option is exactly the same as clicking on the URL with your left 
mouse button.

Save Document to 
Disk Saves the document that is pointed to by the hyperlink (without 

loading the document).    The document is saved with the extension
.htm and can later be opened using the Open URL command.

Get Document 
Information Displays the document header information; i.e., the resource type, 

size, full pathname, etc.    This is a good way to decide whether you 
will want to load in a document (and whether you have the 
appropriate viewers for it), before actually loading it.

Copy Document URL Copies the Document URL (e.g. http://www.bakerstreet.com) to
the Windows Clipboard, so that it can be pasted into other Windows 
applications (or other Mosaic dialogs).

Image Options
Load Image Same as the Load Document option, above, but loads the 

currently selected image.    This is a useful option to use if you have 
turned off the Autoload Inline Images option.

Save Image to Disk Saves the displayed image to disk. 
Get Image 
Information Displays the image header information; i.e., image type, size, full 

pathname, etc.    As with Document Information, above, this will 
help you decide whether you want to load in an image.

Copy Image URL Same as the Copy Document URL option, but copies the images 
URL to the Windows Clipboard.



Cancel Current Task
If at any time you need to stop loading in a document, you can click the Stop button or 
choose Cancel Current Task from the Navigate menu.



Viewing Inline Images
Mosaic home pages frequently display graphical inline images.    By default, Mosaic will 
load in text, then load in inline images; you can control whether the inline images are 
loaded, and how often they are loaded, using options in Mosaic.
If you are using Mosaic over a slow connection, you may want to change these settings.    
You may also want to change these settings if you are not interested in viewing the 
images.    
The Autoload Inline Images option found in the Options menu and in the 
<Configuration> dialog will allow you to specify whether images are loaded.    If you 
choose not to use this option (due to a slow connection, or other reason), you can load in 
images that you need selectively using Mosaic’s Quick Menu feature.
Note: Some images in Mosaic are used as hyperlinks; if you turn off Autoload Inline 

Images, most home pages will display an alternate method for accessing the 
hyperlinks.    However, some images, called image maps, have multiple hyperlinks 
included in them; in these cases, you will often have no other way of accessing 
hyperlinks. 

When you connect to a Mosaic document, Mosaic loads in the entire document, using 
image “placeholders” for any images in the document.    Mosaic will then load in the 
images one by one, and redraw the screen (replacing the placeholders with images) as 
images are loaded in.    
You can change how often the screen is redrawn by changing the When loading images,
redraw every __ minutes option found in Mosaic’s <Configuration> dialog.    See 
Configuring Mosaic Options for more information on using this option.



The Mosaic Console
The Mosaic Console is described below.
The Toolbar at the top of the Console contains buttons that serve as shortcuts for Mosaic 
menu items.    The Toolbar style can be changed between Picture & Text, Picture only, and 
Text only by choosing Toolbar Style from the Options menu.    
The Status Bar at the bottom of the Console displays the locations of resources you 
connect to, as well as indicating when a transfer is in progress or a graphic is being 
loaded. 
Both the Toolbar and the Status Bar can be shown or hidden by checking or unchecking 
Show Status Bar or Show Toolbar using the Configuration option in the Options menu.
Below the Toolbar is the Document Title Bar, containing the Document Title and 
Document URL drop down lists.    The two lists contain a listing of the last several 
documents you have accessed.    The lists are identical, but one shows the Title of the 
document (such as "The Internet Movie Database") and the other shows that document's 
URL (http://www.msstate.edu:80/Movies).    You can go back to any of the displayed 
documents by choosing its title or URL from the lists.    You can change the number of 
documents that are displayed in these lists using the Configuration option in the Options 
menu.
The Document Title Bar also contains the globe icon.    This icon moves when a 
document is being loaded or a graphic is being transferred (roughly, it indicates that 
Mosaic is busy).    You can disable the animation of this icon by unchecking Animate logo 
using the Configuration option in the Options menu.
You can temporarily hide the Toolbar and Document Title Bar using Kiosk Mode.



Using Kiosk Mode
Kiosk Mode is available with Mosaic; you can hide all the Console information except the 
actual document (in other words, the Toolbar, Status Bar, and Document Title Bar and the 
menu items and commands will be hidden).    This may be a useful mode to use when 
giving Mosaic presentations (it shows a lot of the screen) or when setting up Mosaic on an 
unattended workstation.

1. Choose Kiosk Mode from the Options menu.    Mosaic will change into Kiosk 
Mode.
You can move around in Mosaic as you would normally, except that the Toolbar 
buttons and menu options are not available to you.
Note that the shortcut movement keys of F (for Forward) and B (for Back) will be 
very helpful to you to move when in this mode, since the Forward and Back 
commands are not available.

2. Click the Esc key or Ctrl-K to exit Kiosk mode.



Using Hotlists
Hotlists allows you to organize the information that you find on the World Wide Web.    
There are so many documents out there with useful jumps to resources you might be 
interested in, that it is common to want to access these documents again and again.    You 
can save these documents and open them again later, but Mosaic provides an easier way 
to re-access documents.
Mosaic's Hotlists can be used to remember WWW document locations, so that you can 
easily locate and access them.    You can group Hotlists by subject (Games, Sports, 
Weather, Fun Stuff) or by any other criteria (if several people use one computer, they 
might each have their own hotlist).    
Hotlists you create can then be accessed two ways:    they can be accessed with a couple 
of mouse clicks from the convenient Hotlists dialog, or you can make Hotlists into drop-
down menus, so that you can choose them directly from the Mosaic menu bar.
Note: NCSA Mosaic users:    You can convert any menus you created in NCSA Mosaic 

to Hotlists.

See
Hotlists 
Creating a New Hotlist 
Adding a Document to a Hotlist 
Exporting a Hotlist 



Hotlists
The <Hotlists> dialog is used to create and select Hotlists, lists of WWW documents that 
are organized for easy access.    You can use Hotlists to quickly jump to WWW documents, 
and add Hotlists to Mosaic menus.
Hotlists are shown as "flaming" documents in the <Hotlists> dialog.    Initially, Hotlists 
may be shown closed; you can open up (expand) the Hotlist by double-clicking on the 
Hotlist icon.    Each Hotlist can list many WWW documents and folders containing 
additional documents.    You can use folders and subfolders to organize your documents 
any way you want.    You will see the documents and folders listed in a hierarchy similar to 
the Windows File Manager.    
You can immediately go to any document in a Hotlist by double-clicking the document 
name in the Hotlists dialog.

Adding Hotlists to the Menu
At any time, you can check Use Hotlist as menu item to have a Hotlist added as a menu 
item.    You can add as many menu items as can fit in your Mosaic menu bar.    When you 
choose this option, the Hotlist icon in the <Hotlists> dialog will change to a dialog 
containing the letter H.    If you add a Hotlist as a menu item, any folders within that 
Hotlist will appear as menu items that have sub-menu items beneath them.
You can create a new Hotlist, add documents or folders to an existing Hotlist, and export a
Hotlist as an HTML file; click on the option below for more information.

See
Creating a New Hotlist 
Adding a Document to a Hotlist 
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Creating a New Hotlist
Choose Hotlists from the File menu, or click the Hotlist button on the Toolbar.    The 
<Hotlists> dialog will appear, containing any hotlists already created.
Click the Open/New button.    You will see the <Open/Create New Hotlist> dialog, allowing
you to create a new Hotlist.    (You could specify the name of an existing hotlist at this 
point, to open and load it into the <Hotlists> dialog.)
Choose a filename for your Hotlist, and click OK.    This must be a legal DOS filename 
(using up to 8 characters, with the extension .hot).
The next dialog asks you to specify a name for this Hotlist.    This can be any name you 
want (keep in mind that you may want to use this hotlist as a Mosaic menu, so you might 
want to keep the name short).    Type a name, and click OK.
The Hotlist will be created, and you will see it appear in the <Hotlists> dialog (as a 
"flaming" document).
You may want to create folders or subfolders to help organize your information.    To do 
this, click Add with the Hotlist highlighted (or with a folder highlighted to create a 
subfolder), and specify Folder in the dialog that appears.    You will be asked to name the 
folder. Give it a name and click OK; the folder or subfolder will be created.
Now that you have a Hotlist, you can begin to add documents to it.

See
Add Documents to a Hotlist 



Open/Create New Hotlist
The <Open/Create New Hotlist> dialog can be used to open an existing Hotlist, or create a
new Hotlist.
In this dialog, specify the name of an existing Hotlist, to open and load it into the 
<Hotlists> dialog.
or
Specify the name of a new Hotlist to have Mosaic create a new Hotlist for you.    Choose a 
filename for your Hotlist, and click OK.    This must be a legal DOS filename (using up to 8 
characters, with the extension .hot).



Adding a Document to a Hotlist
There are several different ways to add documents to a Hotlist.    Click on the option below
for which you want help.
Add the current document to a Hotlist.
Drag and drop a document hyperlink into a Hotlist
Copy a document URL and paste it into a Hotlist.
Add a document to a Hotlist manually.
Note: The first three options allow you to add a document to your Hotlist without having 

to know or remember the document’s URL.



Adding the Current Document to a Hotlist
In Mosaic, display the document that you want to add to a Hotlist.    You can then add it to 
the current Hotlist, or add it to any of your Hotlists using the <Hotlists> dialog, as 
described below.

Add using the Add Document option:
n Click Add Document to Hotlist in the Navigate menu to add the document to 

the Hotlist you are currently using.    The document will be added to the end of the 
last Hotlist or folder you selected.    You can open the <Hotlists> dialog if you are 
not sure which Hotlist is currently selected.

Add using the Hotlists Dialog:
1. Click the Hotlist button, or choose Hotlists from the File menu.
2. Select the Hotlist (or Hotlist folder) to which you want to add the current document.
3. Click Add (or click Insert to insert the document under the currently selected 

document).    You will be asked whether you want to add a document or folder; 
select Document.    You will see a dialog containing the Name and URL of the 
document you are currently viewing.    If you wish, you can change the name of the 
document.    Do not change the URL!

4. Click OK.    The document will be added to the Hotlist you selected.



Drag and Drop a Document Hyperlink into a Hotlist
You can drag and drop a document into a Hotlist, if you wish.    The hyperlink (“jump”) to 
the document should be displayed on the screen to do this.

1. Click the Hotlist button, or choose Hotlists from the File menu.        Open the 
Hotlist and folder you want to move the document into.    Move the <Hotlists> 
dialog on your screen so that you can also see the hyperlink for the document you 
want to add to the Hotlist.

2. Select a document hyperlink by holding down your mouse until the cursor changes 
to a document icon, and drag it to the Hotlist or Hotlist folder you want.    You will 
be prompted to give the Hotlist a name.



Copy and Paste a Document URL
If you wish, you can copy a document’s URL information to the Windows Clipboard and 
then easily paste it in the <Add Hotlist> dialog, so that you do not have to type a long 
URL in the <Add Hotlist> dialog.
You can copy a document URL from any Windows application by using the Copy command
in that application.    You can also copy a document URL that you see on your Mosaic 
screen by clicking on the document URL with your right mouse button and holding it 
down, then selecting the Copy Document URL option in the Quick Menu that appears.    
You can then open the <Hotlists> dialog, select the Hotlist and/or folder that you want to 
add the document to, and click the Add button.    Choose Document to add a new 
document.    In the <Add Document> dialog, put your cursor in the URL field, and click 
Ctrl-V (the Paste shortcut key) to paste the document URL into the URL field.



Adding a Document to a Hotlist Manually
You might do this if you want to add a document to a Hotlist, but do not currently have the
document open.    To do this, you need to know the URL (address) for each document.    For
instance, someone may give you a list of WWW documents containing travel information.   
You might create a Travel folder in one of your Hotlists, and add all the WWW documents 
to it.    This process is described below.

1. Click the Hotlist button, or choose Hotlists from the File menu.    
2. Select the Hotlist to which you want to add a document by highlighting it using 

your mouse.
3. Click Add.    You will be asked whether you want to add a document or folder; select

Document.    You will see the <Add Document> dialog.    If you currently have a 
document open, the information about that document will appear in this dialog. 
For the Document name:, type any name you want for this document.    It should be
a name that will help you recognize this file.
For the Document URL: field, type the Document’s URL.    See the “Understanding 
URLs” section for more information on using URLs.

4. Click OK.    The document will be added to the Hotlist you selected.



Export Hotlist
The <Export Hotlist> dialog, accessed by clicking the Export button in the <Hotlists> 
dialog, can be used to export any of your Hotlists as an HTML file (a Mosaic-format 
document).    You might do this to make the information in the Hotlist available for other 
browsers to access, or you might want to use the Hotlist as your default home page, so 
that you immediately have a list of your favorite resources available when you start 
Mosaic.
You should specify a name and location for the HTML file.    Select the directory you want 
for the file, and choose a name for the file.    Click OK to export the Hotlist.    The file will be
saved with the extension .htm by default.
After you export the file, you can open the file by using the Open command in the File 
menu.    Your Hotlist will be displayed as a Mosaic document that resembles your hotlist 
and contains hyperlink jumps for documents in your hotlist.



Import NCSA Menu as Hotlist
If you previously used NCSA Mosaic (from the National Center for Supercomputing 
Applications), you may have built up extensive menus of favorite home pages and 
resources. Mosaic allows you to convert these menus to Mosaic Hotlists so that you can 
use them just as you would Hotlists created in Mosaic.    

To import an NCSA menu as a Hotlist:
Click Import NCSA Menu as Hotlist in the Options menu.    You will see the <Import 
NCSA Menu as Hotlist> dialog.
In the dialog's INI file to import from field, you should specify the name and location of the
MOSAIC.INI file where your NCSA menu information is stored.    You can click the Browse 
button to browse the directories on your PC and select the correct file.    Once you have 
selected the file, you can confirm that it is the correct file you want by clicking the Open 
button.
You should then specify a Hotlist file for this menu.    Do not choose an existing Hotlist 
unless you want to overwrite the information in that file.     Again, you can use 
Browse to find a Hotlist file and a directory for the file.
Last, you should specify which menus from that NCSA MOSAIC.INI file you want to import 
(all the menus identified in that file should appear in a list).    Click OK when you are ready
to import the file.
The next time you open the <Hotlists> dialog, the menu(s) you imported should be 
displayed.    You can add them as menu items, if you like, using the Put this Hotlist in the 
menu bar command.



Opening Mosaic Documents
There are two ways to open a WWW document directly.    If you know the document's URL 
(Uniform Resource Locator; a standard "address" for Mosaic documents), you can access 
the document by typing the document's URL.    If someone tells you the URL of a popular 
WWW site on the Internet, you can go to it directly using that URL.    You will also need to 
know a document's URL to set it up in a Hotlist or as a default home page.
You can also create or save an HTML file directly to your PC, and open it in Mosaic.    This is
known as a Local File.    
These two methods of opening Mosaic documents are listed below.

See
Opening Documents using URLs 
Opening a Local File 



Opening Documents using URLs
Mosaic locates documents by using URLs, Uniform Resource Locators.    URLs are a 
standard notation for WWW resources, designed to be able to identify information stored 
on a variety of machines, in a variety of different ways. A URL can point to resources such 
as an HTML document (a WWW home page), an ftp server, a gopher server, or a local 
document.    When you access a document in Mosaic, you will see the URL for that 
document shown in the Document URL: field    displayed below the Mosaic Toolbar.
URLs are used to    indicate the type of the resource and where it is located, as well as the 
resource name.
If you know the URL of a resource, you can access it directly, as described below.
Click Open URL in the File menu.
The most common URL you will specify in the <Open URL> dialog is the URL for an HTML 
home page.    This is always preceded by http:// followed by the address of the HTML 
document, e.g., http://www.bakerstreet.com/221B.html
Type the URL you want to connect to and click OK.    If the URL is valid, Mosaic should 
begin connecting to it.

See 
URL Description 



URL Description
URLs typically provide information about a resource type, location, and path.    
You might find a document called “Unsolved Cases” with a URL of
http://www.bakerstreet.com/sholmes/cases/unsolved.html
This URL can be broken into three components
http:        //www.bakerstreet.com    /sholmes/cases/unsolved.html
These three portions are described below.
Resource Type
The Resource Type tells you the type of server on which the resource resides.    The 
resource type is the kind of protocol that will be used when retrieving the document.
URL resource types and formats include:

http:// HTTP (HyperText Transfer Protocol) Server.    This is a site designed 
principally for hypertext WWW documents.

ftp:// FTP (File Transfer Protocol) Server.
file:// Local HTML File (also sometimes used to denote FTP Servers).
telnet:// Telnet Server.
gopher:// Gopher Server.
wais:// WAIS Server (not directly supported in Mosaic)
news: USENET news site

Note: The news: URL uses a slightly different format; it takes the format 
news:newsgroup.name, since you already have a news server pre-defined in 
Mosaic (using the <Configuration> option).    Click Configuring your News Server 
to find out how to configure your news server, and click News Using Mosaic for 
more information on news URLs.

Resource Location
This is the Internet address of the machine where the resource resides.
In the example above, www.bakerstreet.com is the name of the World Wide Web server
that contains the home page.    In some cases, you will be able to tell where a machine is 
located based on the address; for instance, www.websites.de would be a home page in 
Germany; .de is an extension for home pages in Germany.
Pathname {filename}
In most cases, the URL for a document or other resource contains a full pathname for the 
file.    If you are familiar with DOS or UNIX pathnames,    the path in a URL is very similar.    
(Paths in WWW always use the forward slash /).
In the example above, the path is /sholmes/cases/unsolved.htm.    Note that the path 
for a home page can contain a filename, but does not have to; /sholmes/cases/ is also a 
valid pathname.    Certain URLs, such as a URL for an FTP site, may not contain a 
pathname at all; e.g., ftp://ftp.bakerstreet.com.
Some sample URLs are shown below:
http://www.federation.gov/Enterprise/Missions
ftp://ftp.circe.com



ftp://jwatson@ftp.bakerstreet.com
file://localhost/c:\mosdocs\myhome.htm
telnet://odysseus.circe.com:70
gopher://gopher.deathstar.com:70/11/fun/Movies
news:alt.tv.seinfeld
Click Using Mosaic for FTP, Gopher, News, and Mail for more information on accessing ftp, 
gopher, news, and mail using URLs.
Note: For advanced information on URLs, a URL primer is available from NCSA on the 

NCSA home page, at http://www.ncsa.uiuc.edu/demoweb/url-primer.html.



Opening a Local File
You can create an HTML file or save an HTML file directly to your PC, and open it in Mosaic.
This is known as a Local File.    A Local File should have extension .htm.    
You can open a Local File using the <Open Local File> dialog.    Specify the name and path 
for this file, and click OK.    Mosaic will try to open the file you specified.



Using Mosaic for FTP, Gopher, News, and Mail
Although you may navigate principally between HTML documents ("home pages") when 
using Mosaic, you can also use it to access other Internet resources such as ftp and 
gopher sites and USENET news.    The functionality of Mosaic as an ftp, gopher, or news 
browser is somewhat limited, since the World Wide Web protocols used are not very 
sophisticated.    For full-featured use of ftp, gopher, and news, more sophisticated 
applications are recommended.    You can also use Mosaic to send mail.
Click on the option below for which you want information.
FTP Using Mosaic 
Gopher Using Mosaic 
News Using Mosaic 
Mail Using Mosaic 



FTP Using Mosaic
Mosaic incorporates ftp functionality and can be used to browse and retrieve files from 
FTP sites.    Some background on using ftp may be helpful to you in understanding how ftp 
works.
FTP sites in Mosaic will be displayed in a hierarchical folder format in the Mosaic Console. 
You will only see two types of items, folders (directories) and files.    You can navigate 
through folders by double-clicking on them to move deeper into the folders; if you want to
move back, click on the up arrow shown at the top of the folder list.
When you double-click on the name of a file, Mosaic will automatically download (copy) 
the file to your \...\DATA directory, using the displayed filename.

Getting to an ftp site:
You may find hyperlinks to ftp (file transfer protocol) sites when you are using Mosaic, or 
you can connect to a site directly if you know its URL (address).    The format for an ftp 
URL is:
ftp://ftp.narnia.com
where ftp.narnia.com is the site you want to reach using ftp.
Alternately, if a username is required to ftp to the site, you would type
ftp://lucy@ftp.narnia.com
where lucy is your username on the remote site.    You will be prompted for a password. 
Alternately, you can provide the password using the following format:
ftp://lucy:cslewis@ftp.narnia.com
where cslewis is lucy's password on ftp.narnia.com.



Gopher Using Mosaic
You may find hyperlinks to gopher sites when you are using Mosaic, or you can connect to 
a site directly if you know its URL (address).    Mosaic incorporates gopher functionality 
and can be used to browse and use gopher links.    Some background on using gopher may
be helpful to you in understanding how gopher works.
The gopher site will be displayed in a hierarchical file format in the Mosaic Console.    You 
will see folders (directories), and several different types of items: files such as image files, 
sound files, and applications; database search tools; links to telnet and 3270 sites.    
Double-clicking on a file in gopher will either download it to your \...\DATA directory or will 
open it, depending on whether you have a Viewer for that file configured in Mosaic 
(Mosaic examines the gopher file extensions to decide which viewer to use).    If you click 
on a telnet or tn3270 link, Mosaic will use the telnet or tn3270 application defined in the 
<Viewers> dialog.



News Using Mosaic
USENET news is a forum for discussion (similar to a bulletin board system, but on a 
greater scale) that is found on the Internet.    Some World Wide Web home pages contain 
links to newsgroups that you may wish to access.    You may also want to directly connect 
to news as described below:

Connecting to a newsgroup directly:
You can directly connect to a newsgroup using Mosaic by specifying the news URL in 
Mosaic dialogs (such as the Open URL dialog) in the format
news:alt.smurfs
where alt.smurfs is the name of the newsgroup you want to access.
Note: If you use Mosaic’s built-in news function, wildcards are also supported.    This 

means that you can list multiple newsgroups by typing news:* to list all the 
newsgroups on a news server, or news:alt.tv.* to show all the newsgroups with 
names starting with alt.tv, etc.

Mosaic allows you to access news using either the SPRY News application or Mosaic’s 
built-in news function.    If you have SPRY News on your system, Mosaic will automatically 
try to use SPRY News whenever you try to access a newsgroup or news article.    SPRY 
News is a sophisticated news application that will provide additional functionality over the 
built-in news reader.    You can access SPRY News by choosing News from the Tools menu,
or by clicking the News button on the Toolbar. 
If you do not have SPRY News, or if you would prefer to use SPRY Mosaic’s built-in news 
function, you should select the Use Built-in Mail/News option in the Mosaic 
<Configuration> dialog to have Mosaic use the built-in news function.
Important!    Whichever method you use to read and post news, you will have to have 
access to a News Server in order to read News.    If you will be using Mosaic’s built-in news 
function, you can set the news server address by adding it to the News Server field in 
the <Configuration> dialog.    See the SPRY News documentation for information on how 
to set up a news server address for SPRY News.
If you will be using SPRY News, each time you access a newsgroup through Mosaic (no
matter how you access it), the SPRY News application will be started, and will connect to 
the newsgroup that was specified.    See the documentation for SPRY News for information 
on using SPRY News to read and post news.    
If you will be using the built-in news function, click on the options below for 
information on how to read and post news.
Reading News in Mosaic
Posting News Articles in Mosaic



Reading News in Mosaic
When you first see a list of newsgroups, descriptions of all the newsgroups will be 
displayed; to disable this feature, uncheck Extended News Listing in the 
<Configuration> dialog.    Note that unchecking this option will disable threading in 
news.
Once you are connecting to News using Mosaic, and displaying a newsgroup,    the news 
function will display news articles as bulleted items on the screen. 
Articles whose titles are not preceded by Re: are original threads — they represent the 
initial article on a particular topic.    Articles whose titles begin with Re: are responses to 
an initial article.    Mosaic displays hyperlinks at the top of the screen that you can click on 
to navigate through threads.    When you are viewing an article that is part of a thread, 
you will see either Next thread or Next article in thread and Previous article in 
thread, depending on where you are in the thread.
To view an article, simply click on its title in the article list.    You can use the Back button 
on the Toolbar to move back to the original list of articles.



Posting News Articles in Mosaic
You can add an article to a newsgroup (post an article) in Mosaic.    Note that you must 
have rights to post on the current news server in order to post a news article.
When you are viewing a list of news articles in Mosaic, you will see a Post to newsgroup
hyperlink at the top of the screen.    Clicking on this hyperlink will produce a Post News 
posting dialog allowing you to post a news article.
When you are viewing an individual article in Mosaic, you will see a Followup to 
message hyperlink.    This also produces the <Post News> dialog, but will automatically 
include the text of the currently displayed article in that dialog (using standard follow-up 
format).
You can also post or follow-up a news article directly using a URL, with the following 
syntax:
newspost:newsgroupname{,newsgroupname,newsgroupname}{/followup}
where
newsgroupname is the name of the newsgroup you want to post to (you can specify 
multiple newsgroups by separating them by commas)
/followup indicates that you want the posting to be a follow-up posting and include the 
currently displayed article text (if no article is displayed when you do this, no text will be 
included)
Examples:
newspost:alt.tv.seinfeld
newspost:rec.bicycles,rec.sports.cycling
newspost:alt.suburbia/followup
The <Post News> dialog will then be displayed, allowing you to post a message.



Post News
The News dialog allows you to post news messages to a News Server.    You can produce 
this dialog by using the newspost: URL; this dialog will also appear if you click on a 
hyperlink for a newsgroup.
The Sender field will be filled out automatically with your e-mail address; this is obtained 
from the Email Address option in the <Configuration> dialog.    If this value is incorrect, 
you should change it; otherwise, noone will be able to reply to your posting.
The Newsgroup field will be filled out with the name of the newsgroup you were viewing, 
or the newsgroup you specified using the newspost: URL.    You can change this field, if 
you wish to post the article to a different newsgroup, or add additional newsgroups to post
the message to.    
The Subject field is optional (but strongly recommended); fill this out with the subject of 
your message. (This will be filled out automatically if this is a follow up posting).
The Keywords field allows you to specify keywords that will appear in the header of the 
news posting; these keywords are used by some news readers when searching for 
messages.    Some sample keywords are: politics, simpsons, jobs.
Type the message body in the space provided.    All standard Windows editing keys (arrow 
keys, Home, End, Delete, etc.) are supported.
You can drag and drop text files from Windows File Manager into your news article, if you 
wish.    To do this, drag the file and drop it into the text window of the Mosaic News dialog.  
The text in the file you dragged and dropped will display in that window; you can then edit
the text or add new text, as desired.    
Note: You can also indicate the Content (or MIME) type of the item you dragged and 

dropped.    Currently, only text files are supported; text/plain will be selected by 
default.    You can change the type to another text type, if desired.

Click Send to post your news article.



Mail Using Mosaic
Mosaic can be used to send out electronic mail.    You may find hyperlinks that sends mail 
(many home pages provide such links so that you can send feedback about the home 
page, or reach the home page’s creator).    Mosaic also has a link in the Help menu that 
allows you to send feedback mail to SPRY.    Hyperlinks that send mail have the URL 
mailto:lucy@narnia.com.
You can also send mail directly from Mosaic by choosing Open URL in the File menu, and
typing:
mailto:lucy@narnia.com
where lucy@narnia.com is the e-mail address you want to send mail to.
Mosaic allows you to send mail using either the SPRY Mail application or Mosaic’s built-in 
mail send function.    If you have SPRY Mail on your PC, Mosaic will automatically try to use
SPRY Mail whenever you try to send out mail.    You can access SPRY Mail directly by 
choosing Mail from the Tools menu or by clicking the Mail button on the Toolbar.    SPRY 
Mail features advanced functionality, including an address book feature and the ability to 
receive mail.    
Important!    You must have a POP3 e-mail account in order to use SPRY Mail.
If you do not have SPRY Mail, or if you would prefer to use SPRY Mosaic’s built-in mail 
function, you should check the Use Built-in Mail/News option in the Mosaic 
<Configuration> dialog in order to have Mosaic use the built-in mail send option.    In order
to use the Built-in Mail feature, you must have an SMTP Gateway defined in the 
<Configuration> dialog.    Note that SPRY’s built-in mail function does not allow you to 
receive mail.
If you will be using SPRY Mail, each time you try to send mail from Mosaic, the SPRY 
Mail application will be started.    If you have to login, the login dialog will be displayed, 
and you will have to fill it out.    If you accessed mail using a mailto: URL (or clicked on a 
hyperlink that specified a mailto: URL), the <Compose> dialog will be opened with the 
send mail address filled out for you.
If you will be using the built-in mail function, click on Sending Mail in Mosaic for 
more information on sending mail.



Sending Mail in Mosaic
You can send mail by choosing Open URL in the File menu, and typing
mailto:lucy@narnia.com
where lucy@narnia.com is the e-mail address you want to send mail to.
You can also reach the Mosaic mail function by choosing a URL that points to a mail link.
A <Send Mail> dialog will appear allowing you to compose and send a mail message.



Send Mail
The Mail dialog allows you to send out mail from Mosaic via an SMTP Gateway.    You can 
produce this dialog by using the Mailto: URL; this dialog will also appear if you click on a 
hyperlink that sends mail (many home pages provide such links so that you can send 
feedback about the home page, or reach the home page's creator).
The Sender field will be filled out automatically with your e-mail address; this is obtained 
from the Email Address option in the <Configuration> dialog.    If this value is incorrect, 
you should change it; otherwise the recipient will not be able to reply to your mail.
The Recipient field may already be filled out, depending on how Mail was started.    You 
can change this field, if you wish to send the mail to other people.    This field only accepts
standard e-email addresses (such as lucy@narnia.com).    A CC field is also provided; you 
can type e-mail addresses of other people to whom you want to send a copy of the mail.
The Subject field is optional; fill this out with the subject of your message.
Type the message body in the space provided.    All standard Windows editing keys (arrow 
keys, Home, End, Delete, etc.) are supported.
You can drag and drop text files from Windows File Manager into your mail message, if you
wish.    To do this, drag the file and drop it into the text window of the Mosaic mail dialog.    
The text in the file you dragged and dropped will display in that window; you can then edit
the text or add new text, as desired.    
Note: You can also indicate the Content (or MIME) type of the item you dragged and 

dropped.    Currently, only text files are supported; text/plain will be selected by 
default.    You can change the type to another text type, if desired.



HTTP/0.9
Some older WWW documents may require you to use an earlier version of the HyperText 
Transfer Protocol, HTTP /0.9, to access them.    In most cases, the hyperlinks to those 
documents will warn you that HTTP /0.9 is required to read them.    Mosaic allows you to 
use this option in order to read these earlier documents.



Saving Mosaic Documents
You may sometimes want to save documents, files, and images you find using Mosaic.    
There are several different ways to save items in Mosaic.    Click on the item below for 
which you want information.
Saving Items Using Mosaic's Quick Menu
Drag and Drop the Item
Save the Item using Load to Disk Mode 



Saving Items using Mosaic's Quick Menu
You can use Mosaic's Quick Menu feature to save a document, file, or image to your PC.    
Click on the item’s hyperlink with your right mouse button and hold it down, then select 
the Save Document to Disk or Save Image to Disk option (whichever is appropriate) 
in the Quick Menu that appears. 



Using Drag and Drop in Mosaic
You can drag and drop Mosaic items to the Windows File Manager, or to other applications 
that support drag and drop, such as Microsoft Word.    When you drag items to the File 
Manager, they will be saved as files on your system.    When you drag items to a Windows 
application, they will be treated in the same way as other items dropped in that 
application.
You can also drag images to your desktop, and use them as your Windows wallpaper.
Note: When you drag and drop images from Mosaic, they will be saved as Windows 

bitmap images, regardless of their original format.    If you want to save an image 
in its original format, save the image by using the Quick Menu option.

To drag and drop a Mosaic item: 
1. With your mouse cursor over a hyperlink, click and hold down the mouse button 

until the cursor changes from a pointing finger to a document icon.    
2. Continue holding down the cursor, and drag the item to its destination. If the image

cannot be dropped on that location, the cursor will change to a    symbol, and you 
will not be able to drop the item.    You may be prompted for a name (and path) for 
the item, depending on the type of the dropped item. 
If you drag it to the File Manager, the item will be copied into the directory where it 
was dropped.    Note that images will always be saved as .BMP files.
If you drag it to another Windows    application, the item will be treated as any item 
dropped in that application.    You can only drop items on applications that support 
drag and drop.
If you drag an image to the Windows desktop (not an open application), you will be
asked to confirm that you want to use the image as wallpaper.    You will then be 
prompted to save the image.    You can change the name that is suggested, but do 
not store the image in a directory other than the \WINDOWS directory.    When you 
save the image, it will immediately be used as wallpaper; see the Windows Control 
Panel, Desktop option to change the Wallpaper or how it is displayed.



Load to Disk Mode
You can also save all of the Mosaic documents you encounter by using Load to Disk mode. 
Load to Disk mode is a mode you can turn on, that will prompt you to save each item that 
you click on to your system, without loading it.    It is a good method to use to save all the 
information pointed to by a home page quickly and easily, without having to load in each 
image.    
Select Load to Disk Mode in the Options menu (a check mark will indicate that the 
mode is enabled).    When Load to Disk Mode is enabled, each time you try to access a 
document you will be prompted for a name and location to save the item to.    Note that 
the items you access will not be loaded; they will only be saved.    Mosaic will continue to 
try to save documents until you disable Load to Disk Mode by again selecting the Load to
Disk Mode option from the menu.    
If you wish to use Load to Disk Mode selectively, you can turn it on for one download by 
holding down the [Shift] key while you click the item.



Mailing URLs Using SPRY Mail
If you have SPRY Mail, you can use Mosaic’s Drag and Drop feature to mail a URL to 
anyone else who has SPRY Mail and SPRY Mosaic.    They will then be able to double-click 
on the URL and automatically view the home page associated with the URL.
You do this by highlighting a hyperlink and dragging it to the SPRY Mail attachment 
window.    The URL will appear in the attachment window displaying a Mosaic icon.    You 
can then send the mail as you would normally.    If the person receiving the mail also has 
SPRY Mail and SPRY Mosaic, they will be able to doubleclick on the Mosaic icon in their 
mail message to have SPRY Mosaic automatically open the URL and display the associated
home page (this will work regardless of whether SPRY Mosaic is open).
Note: The URL you are mailing is a text file.    If you want, you can send the mail to 

someone who does not have SPRY Mosaic or SPRY Mail; they will still be able to 
view the file as a text file, and can copy or paste it to their WWW browser.    (Note 
that they will have to be able to decode what you send using either a uudecoding 
program or a mailer with MIME-support).
In these cases, it may be easier for you to just use the Copy URL function found in 
Mosaic’s Quick Menus. 



Printing in Mosaic
You can print the information in a document to your printer using the Print command in 
the File menu.    You can click the Setup button in this dialog to specify a different printer,
or set up options for printing.
You can choose the Print Margins command from the File menu to change the margins 
of the pages that are printed.
If you want to see how the output will look, you can choose Print Preview to see a 
preview of how the document will print.



Copy
The Copy command allows you to copy text from the Document Title: or Document URL: 
drop down lists.    It cannot be used to copy from the document you are currently viewing 
(you can, however, view the document using the Document Source command in the File 
menu, and use the Copy command in that window).
Once you have copied text, you can paste it in another Windows application using the 
Paste command or shortcut in that application.
Likewise, you can also paste information into Mosaic dialogs (although there is no Paste 
command in the Edit menu).    After using the Copy command in Mosaic or another 
Windows application, you can use Windows shortcut keys, Ctrl-V or Shift-Insert, to paste
text into any Mosaic dialog (a likely use would be to paste a URL from a mail message into
the <Open URL> dialog).



Finding Text in a Mosaic Document
You can search a WWW document for particular text using the Find command.    Click the 
Find option in the Edit menu, and type the text you want to search for in the dialog that 
appears.    The search will occur from the top of the document to the bottom.    If you want 
to search for additional occurrences of the text, you should choose Find Next in the 
<Find> dialog after the first find.



Mosaic Menu Commands
File Menu 
Edit Menu 
Options Menu 
Navigate Menu 
Tools Menu



File Menu
Open URL 
Open Local File 
Hotlists 
Print 
Print Margins
Print Preview 
Document Source 
Exit 



Print Margins
This option allows you to specify the margins to use when printing Mosaic documents to a 
printer; by default, no margins are used.    Set the Top, Bottom, Left and Right margins to 
the settings you prefer.



Exiting Mosaic
You can exit Mosaic by choosing Exit from the File menu.    You can also double-click on 
the Windows System Menu to exit Mosaic.
Note: If you are currently retrieving a new Mosaic document, it is recommended that you

wait until that document is retrieved, or stop retrieving the document by clicking 
the Stop button, before exiting Mosaic. 



Edit Menu
Copy
Find



Options Menu
Load to Disk Mode 
Autoload Inline Images 
Kiosk Mode 
HTTP /0.9 
Configuration 
Toolbar Style 
Import NCSA Menu as Hotlist 



Navigate Menu
Back 
Forward 
Home 
Reload 
History 
Cancel Current Task 
Add Document to Hotlist 



Configuring Mosaic Options
You can easily configure Mosaic using the <Configuration> dialog.    This dialog allows you 
to specify options for displaying elements in the Mosaic Console, such as the Toolbar, 
Status Bar, images, hyperlinks, and sounds; the default servers for Mosaic; Mosaic's fonts 
and colors, and which external viewers are used to view graphics, and play sounds and 
movies.
The <Configuration> options are listed below.    Click the option for which you want help.
General Configuration Options 
Home Page
Email Address
SMTP Server
News Server
Viewers
Color
Fonts
Proxy Servers



General Configuration Options
The General Configuration options shown at the top of the <Configuration> dialog are 
listed below.    Click on the item for which you want help.
Show Toolbar
Show Status Bar
Show Document Title
Show URL
Use Built-In Mail/News
Save last window position
Autoload inline images
Show URL in Status Bar
Underline hyperlinks
Animate logo
Use 8-bit sound 
Extended News Listing
When loading images, redraw after __ seconds 



Show Toolbar/Status Bar
These options control whether or not the Toolbar and Status Bar are displayed.    You may 
not wish to hide the Status Bar as it displays the locations of resources you connect to, as 
well as indicating when a transfer is in progress or a graphic is being loaded.    By default, 
these options are displayed; check them again to hide them.
You can also hide most of the Console options by using Kiosk Mode.



Show Document Title/URL
These options control whether or not the Document Title: drop down list (with the Mosaic 
globe icon), and the Document URL: drop down list are displayed.    You can show both 
options, hide both options, or show only the Document Title Bar.    You cannot display only 
the Document URL: list.    By default, these options are displayed; check them again to 
hide them.



Use Built-In Mail/News
This option allows you to use Mosaic’s built-in Mail and News browsers instead of the SPRY 
Mail and News applications.    If you do not have SPRY Mail or News, or wish to use 
Mosaic’s internal mail and news browsers, check this option. See Using Mosaic for FTP, 
Gopher, News, and Mail for more information on this option.



Save last window position
You may want to resize the Mosaic Console window during your Mosaic session, in order to
see more (or less) of a WWW document.    If you want these size changes to be saved and 
used during your next Mosaic session, check this option.



Autoload inline images
By default, images (such as logos, fancy titles, small photos) are automatically displayed 
on your system when you connect to a World Wide Web site.    This is done by 
automatically downloading the image to Mosaic, where it is kept in your system memory.   
This downloading process can be very time-consuming, depending on the speed of your 
Internet connection.
Mosaic allows you to disable this feature, so that the images are not automatically 
downloaded/displayed.    Uncheck this option to stop viewing graphics.    In the place of the
graphics, you will see graphic placeholders.



Show URL in Status Bar
By default, when you highlight a hyperlink (by moving your mouse over it), the destination
URL for that hyperlink will be displayed in the Status Bar.
You can uncheck this option, if you choose.



Underline hyperlinks
Typically, hyperlinks are displayed in blue and underlined.    You may want to turn off the 
underlining. This is a personal preference; it will not affect the speed that the document is 
retrieved in any significant way.



Animate logo
This refers to the globe icon on the Document Title Bar.    By default, this is turned on, as it
indicates when a document or image is being retrieved (and gives your mind something to
do while you wait–although you can always work in other Windows applications if a 
document is loading too slowly).    The time you'll save by turning off the logo animation is 
not substantial; you will probably only want to turn off that option if your connection is 
very slow.
This option is primarily provided in case you are using a remote access program such as 
Symantec's PC-Anywhere to use your PC remotely.    In these cases, the animated logo 
may cause problems; disable Animate logo by unchecking this option.



Use 8-bit sound
Mosaic features internal sound support for .AU and .AIFF files, using your sound card (if 
you have one).    Mosaic assumes you have a high quality sound card.    If these file types 
do not play properly, or you have a lower quality (or 8-bit) sound card, choose this option.



Extended News Listing
This option, when checked, will display all the newsgroup descriptions when you are listing
newsgroups in Mosaic.    Note that unchecking this option will also turn off news threading. 
See Using Mosaic for FTP, Gopher, News, and Mail for more information on reading news in
Mosaic.



When loading images, redraw every __ seconds
You can change how often the screen is redrawn by selecting Configuration in the 
Options menu, and changing the When loading images, redraw every __ seconds option.   
When you connect to a Mosaic document, Mosaic loads in the entire document, using 
image “placeholders” for any images in the document.    Mosaic will then load in the 
images one by one, and redraw the screen (replacing the placeholders with images) as 
images are loaded in.    
Changing the redraw value will affect how the Mosaic document appears as it is loaded in. 
For instance, if you want Mosaic to load in most/all of the document’s images before 
redrawing the screen, you would set this value to a high number (e.g. 5 seconds), to give 
Mosaic time to load in all the images.    If you want Mosaic to redraw the screen each 
time a new image is loaded in, set this value to a lower number (2 seconds, for 
instance).
The value you will want to use is also dependent on the speed of your connection.    If you 
are operating over a slow modem connection, images may not load in very quickly, and 
you may want to increase the screen redraw value to a higher number (so that the screen 
only redraws when new images are loaded in).
Another reason for changing this value:    if your Mosaic screen is redrawing the screen 
very often, you may find the flicker of your screen as the screen is redrawn to be 
annoying.    If so, increase the value of the redraw option until you are happy with the 
screen performance.



Home Page
Mosaic lets you set up a default Home Page that you can quickly access using the Home 
button on the Toolbar.    Type the URL for the home page in the URL: field to set up this 
home page.    
You can also set up Mosaic to automatically load this Home Page on startup; if you want to
see this home page whenever you start Mosaic, check the Load automatically at startup 
option.



Email Address/SMTP Server/News Server
These options, found in the <Configuration> dialog, are all used by Mosaic when you are 
using some of Mosaic's extended functionality.    Mosaic can be used to read News and 
send mail messages.    
You must fill out some information about your system in order for these to work properly.

To send mail:
You must fill out your e-mail address and SMTP Server address.
Email address
This is the address others use to send you e-mail, e.g. jwatson@moriarty.com.
SMTP Server
This is the mail server you use.    A default mail server on the Internet has been supplied 
for you.    For optimum use, it is suggested that you use your own SMTP server.    Specify 
the address for the server.    This would be an address such as mailserv.narnia.com.

To read news:
News Server
You must fill out the address of your news server.    This is the machine that you connect to
in order to read news.    A News server address is supplied by default.    This news server 
has a limited amount of newsgroups available.    If you have a news server you prefer to 
use to read news, type its name here.

See Also
Using Mosaic for FTP, Gopher, News, and Mail 



Cached Documents
This item represents how many documents are cached, or kept active, in your PC's 
memory.    If this number is 10, for instance, 10 documents will remain "available" to you; 
if you go back to them, they will appear immediately, and will not have to be loaded.    
If you have a lot of available system memory, you may want to increase this number.    
Keep in mind that a high number for cache may affect other applications' performance, 
although Mosaic performance will probably improve quite a bit.



Documents in Drop Down
This value indicates how many of your last-accessed documents will appear in the 
Document Title: and Document URL: drop down lists (displayed beneath the Toolbar).    A 
value of 5 would mean that the last five documents you accessed would display in these 
lists.



Configure Viewers
The World Wide Web includes many different types of items: text, pictures, sound, movies,
and almost every conceivable type of computer file.    Although Mosaic has the ability to 
display text and graphics (GIF and JPEG format) and play .AU and .AIFF sound files, certain
items you will find on the Web require applications other than Mosaic in order to work.    
For instance, MPEG multimedia movies will require you to run an MPEG movie player 
application in order to view the movie.    Applications like the MPEG movie player 
application are referred to as external viewers.
Mosaic is already set up to use two external viewers:    ImageView, a viewer for JPEG and 
GIF files that comes with Mosaic, and Media Player, a sound player that comes with 
Microsoft Windows.    When you try to access JPEG or GIF files, ImageView will be started; 
accessing WAV or MIDI files will cause Media Player to open.
Note: Although Mosaic has built-in support for GIF and JPEG files, ImageView is included

with Mosaic so that you can open these files in a high resolution format, save 
them, and convert them to other formats, if desired.

You may find other items on Mosaic home pages (or FTP or Gopher sites you are viewing 
using Mosaic) that require external viewers.    The <Viewers> dialog allows you to change 
the viewers and tools that are used to access Mosaic resources.    
Click on a topic below for information on using the <Viewers> dialog.
Setting up Viewers
Setting up Telnet, TN3270, and rlogin
Adding New MIME Types



Setting up Viewers
Mosaic uses MIME types to decide how to treat items you try to access on a World Wide 
Web home page.    MIME (Multipurpose Internet Mail Extensions) is a general purpose 
encoding method for exchanging multimedia data over the Internet; files that you find on 
World Wide Web home pages will have predefined MIME types associated with them.    For 
instance, MPEG movie files have type video/mpeg, and TIFF graphics have type 
application/tiff.    You can find out the MIME type of an item by clicking on it with the 
right mouse button and choosing Get Document Information (or Get Image 
Information).      (Note that this information is only available for items on HTTP servers).
When you find an item for which you want to set up a viewer, you will need to know the 
MIME type of the item in order to set up a viewer for that item.    Most standard MIME 
types are included with Mosaic.    If you do not see the MIME type for the item you want to 
define, you will have to create a new MIME type.

Setting up a Viewer:
1. In the Type drop down list, select the MIME type for the item for which you want to 

set up a viewer. 

Warning: When Mosaic accesses files from an HTTP site, it uses only the MIME type to 
decide what type of file it is accessing and how to treat the file; therefore, you 
must be sure that the MIME type you specify is accurate.

2. The Extensions field allows you to define file extensions (i.e. .GIF, .WAV, .DOC) that 
are used to recognize a file.    Note that file extensions are only used when 
accessing files on an FTP or Gopher site; therefore, you only need to provide 
extensions if you think you will be downloading this type of item from FTP or 
Gopher sites.    If you are providing several extensions, you should separate the 
extensions with commas.    Note that UNIX servers sometime have case-sensitive 
filenames; you will probably want to add both upper and lower cases for the 
extension (e.g. .txt, .TXT).

3. In the Viewer field, type the full path and filename of the viewer you want to use 
for items with the MIME type you selected, or click Browse if you are not sure of 
the path for the viewer and want to search for it on your system.

4. You can set up as many viewers as you like.    Click Close when you are done 
configuring viewers.    The changes will take place immediately.

You can change any of the viewer or extension information for a MIME type at any time by 
selecting that MIME type from the drop down list and changing the information that 
appears; clicking Close to exit the dialog will save your changes.



Setting Up Telnet, TN3270, and rlogin
The Telnet, RLogin, and TN3270 fields in the <Viewers> dialog allow you to define which 
applications are used by Mosaic to access telnet, rlogin, and tn3270 URLs.    Type the full 
path and filename for the applications you want to use in the appropriate field, or click 
Browse if you are not sure of the path for the application and want to search for it on 
your system. 
When you Close the <Viewers> dialog, the changes you made will be saved.



Adding New MIME Types
Mosaic includes many standard MIME types.    However, you may at some point need to 
define an entirely new MIME type.    
You might want to do this because you find an item on an FTP or Gopher server for which 
you have a viewer, and want to set up the viewer so that you can open and display that 
type of item.    Note that when Mosaic accesses an item on an FTP or Gopher server, it 
uses the item’s file extensions, not the MIME type, to recognize the item.    Therefore, you 
can create a new MIME type just for that item.    For instance, you might find an FTP site 
which contains diagrams created in Shapeware’s Visio program.    If you have a copy of 
Visio, you might want to create a new MIME type for Visio, called application/x-visio, so 
that you can directly open Visio files from Mosaic using Visio as a viewer.    
Also, you might be accessing an HTTP (World Wide Web) server which contains a new or 
non-standard MIME type, and you want to define that type so that you can specify viewers
for it.    If you are doing this, be sure to use the exact same syntax for the MIME type that 
the server is using.    
MIME types are composed of two parts, a type and a subtype. The type should be one of 
the following:    application, audio, image, text, or video; the subtype defines the 
actual file type.    You specify MIME types by specifying first the type, a forward slash and 
then the subtype, e.g. application/x-visio, where application is the type and x-visio is 
the subtype.    New, undefined MIME types should be pre-pended with an x; i.e. 
application/x-visio.

You can add a MIME type as follows:
1. Click the Add New Type button in the <Viewers> dialog.    A <New Document 

Type> dialog will appear, allowing you to add new MIME types to the Mosaic MIME 
type list.    

2. Type the MIME type name for the new MIME type.    See the previous section for 
information on how MIME types are specified.

3. Click OK to add the new MIME type.    The new MIME type will be added to the Type 
drop down list, and you can now add viewer information to that MIME type.

See
Setting up Viewers



New Document Type
The <New Document Type> dialog allows you to add MIME types to the Mosaic MIME type 
list.    You can specify existing MIME types, or create new ones.    
Specify the MIME type you want to create, and click OK.

See
Adding New MIME Types



MIME Types Included in Mosaic
The table below lists the MIME types that are included in SPRY Mosaic.    The MIME types 
are broken down into type and subtype, and include a brief description of the type of file 
they apply to.

Type Subtype Description
applicatio / Common Ground files

applicatio /iges IGES files

applicatio /mathematica Mathematica files

applicatio /msword Microsoft Word files

applicatio /pdf Adobe Acrobat files

applicatio /postscript Adobe Postscript files

applicatio /rtf Rich Text Format files

applicatio / Word Perfect 5.1 files

applicatio /zip ZIP (compressed) files

audio /aiff Audio Image File Format audio files
audio /basic Sun/DEC/NeXT audio (*.AU) files
audio /wav Microsoft Windows WAVE (RIFF) audio 

files
audio /x-midi MIDI audio files
image /gif CompuServe GIF images
image /jpeg JPEG compressed images
image /targa AT&T Targa images
image /tiff Tagged Image File images
image /x-win-bmp Microsoft Windows Bitmap images
text /html HTML formatted text files
text /plain Plain ASCII text files
text /richtext Richtext text files
video /mpeg MPEG movie files
video /msvideo Microsoft Video (.AVI) files
video /quicktime Apple Quicktime movie files

Further Information About MIME
Technical information about MIME can be found in the Internet Request For Comments 
document RFC 1521 and 1522.    A complete list of RFCs can be found at:
ftp://DS.INTERNIC.NET/rfc
The frequently asked questions documents for MIME can be found at 



http://www.cis.ohio-state.edu:80/hypertext/faq/usenet/mail/mime-faq/top.html
A list of currently registered MIME types can be found at:
ftp://ftp.isi.edu/in-notes/iana/assignments/media-types/media-types



Color
The Hyperlink color is the color that is used to highlight Mosaic hyperlinks (jumps to other 
documents or document areas, or jumps to resources).    Text hyperlinks are entirely 
highlighted, and graphics hyperlinks are surrounded by a highlight.    The standard 
Hyperlink color is blue.
To change the Hyperlink color, click Color.    The <Color> dialog will appear.
Select the color you would like to use for Hyperlinks, or click Define Custom Colors to 
select a color.    Click OK; the Hyperlink color will be changed immediately.



Fonts
You can change the fonts that Mosaic uses to display documents.    You can change the 
font that is used for a particular item, or the font size.    You might want to do this to make 
documents easier to read, or to fit more information onto your screen.    
Different items in documents use different font styles (similar to styles in word 
processors).  Most regular text is displayed in Normal style, and headers are displayed in 
a Header style, such as Header 1, Header 2, Header 3, etc.
You can change these font styles clicking the Fonts button.    You will see the <Fonts> 
dialog.
If you want to change just one style, you can choose the style that you want to change 
from the drop down menu, and define a Font for that style by clicking the Change Font 
button.
Specify the font type and style you want, and click OK.    The style will be changed until 
you change it again.
If you are not sure what style it is you want to change, you will have to do some 
experimenting.    Mosaic cannot tell you what styles are being used in a particular WWW 
document.
If you want to change all the styles in a document, you can choose Enlarge All or 
Reduce All to enlarge or reduce the styles.    You can choose this option as many times as
you like.
Click OK when you are finished changing styles.



Proxy Servers
Some networks that are connected to the Internet are protected by Internet firewalls.  An 
Internet firewall is a software product that consists of a number of proxy servers for 
popular Internet services.    You will not be able to access certain services on the Internet 
without going through these proxy servers.    Requests for information must go through 
the Proxy Servers, which forward the requests outside the network; likewise, when an 
outside network requests information, it must be filtered through the Proxy Servers.
When you request information, Mosaic sends information via the HTTP protocol to the 
Proxy Server, which then sends the information on using the appropriate protocol.    When 
the requested information is returned, it is returned to the Proxy Server, which sends it 
back to Mosaic using the HTTP protocol.
Mosaic supports Proxy Servers based on the ANS and CERN specifications.    Mosaic can 
support FTP, HTTP/SHTTP, News, WAIS, Gopher (note that ANS and CERN have different 
Proxy Servers available).

Using Proxy Servers in Mosaic
In the <Proxy Servers> dialog, reached by clicking the Proxy Servers button in the 
Configuration dialog, specify the address for each Proxy Server that you will need to use.    
This should be an IP address, such as 165.121.6.6, or a fully qualified domain name, like 
proxy.circe.com.    Note that proxy servers are often all found on the same machine (with
the same port).
If a specific port is also required to access that proxy server, you should specify it in the 
Port field next to the server field.
Click OK when you have finished specifying Proxy Server information.    When you next 
access a service that requires you to use proxy servers, Mosaic will try to use a proxy 
server, if you defined it in this dialog.
Note: In previous versions of Mosaic, you were asked to specify the complete URL for 

each proxy server, and were asked to supply the Port number on the same line as 
the URL, followed by a colon.    If you specify the proxy server information this 
way, it will still work.    

Using the Exclude Domain Option
When you provide Proxy Server address information, Mosaic will always try to access 
information through those Proxy Servers.    However, there may be times you do not want 
Mosaic to use Proxy Servers; the Exclude Domain option in the <Proxy Servers> dialog 
allows you to do this.
For instance, if you are accessing information from your own network (such as ftp’ing files 
from another machine within your network), you will not want to go through the Proxy 
Server to retrieve the information.    Also, if you have another domain within your 
organization that is also behind your Internet firewall, you may want to communicate 
directly with machines in that domain, rather than going through the proxy server.
When you specify a domain in the Exclude Domain field, Mosaic will automatically try to 
connect to any URLs in that domain directly, not going through the Proxy Server.    
You can specify multiple domains in this field, separating them by commas.



Tools Menu
Mail
News



Mail (Tools menu)
This command launches a copy of SPRY Mail, if you have SPRY Mail on your system.    You 
can also launch SPRY Mail by clicking the Mail button on the Toolbar.

See Also
Using Mosaic for FTP, Gopher, News, and Mail 



News (Tools menu)
This command launches a copy of SPRY News, if you have SPRY News on your system.    
You can also launch SPRY News by clicking the News button on the Toolbar.

See Also
Using Mosaic for FTP, Gopher, News, and Mail 



Viewing Mosaic Document Source
A Document Source command is provided in the File menu to enable you to view, and 
save HTML document source code.    Click Document Source to view the current 
documents source code.    
You can now choose Save As from the File menu to save the source code to a file.    
Remember that all the HTML codes will also be saved.    You will be prompted for a name 
for this file.
You can also choose Copy from the Edit menu to copy some or all of the HTML text to the
Windows Clipboard, so that it can be used in other applications.    (Use the Select All 
command to select the entire document.)



Mosaic Command Line Options
Mosaic supports three command line options:    opening a URL (Uniform Resource Locator) 
or local HTML file, starting Mosaic in Kiosk mode, and specifying the INI file for Mosaic to 
use for configuration.    
You can, if you want, change the Properties setting for the Mosaic icon to have the 
command line options take place every time you click on the icon.    (This is not 
recommended when using the options to open a URL or local HTML file; see the note 
below).

Command Line Options

Opening a URL or HTML file upon startup:
AIRMOS.EXE {URL}
(example:    AIRMOS.EXE http://www.bakerstreet.com)
or
AIRMOS.EXE {local HTML file pathname}
(example:    AIRMOS.EXE c:\wwwdemo\mydemo.htm)
This option will automatically open Mosaic and connect to the URL or local HTML file that 
you specify.
Note: If you want to connect to the same URL or HTML every time you start Mosaic, it is 

much easier to specify a default home page in Mosaic than to use the command 
line option.    See Configuring Mosaic Options    for more information on specifying 
a default home page.

Running Mosaic in Kiosk mode:
AIRMOS.EXE -K
This will start Mosaic in Kiosk mode, hiding the Menu Bar, Toolbar, Document Title Bar, and
Status Bar, and displaying only the World Wide Web document you are currently viewing.  
See Using Kiosk Mode for more information on using Kiosk Mode.

Specifying the AIRMOS.INI file to use:
AIRMOS.EXE -I {full path to INI file}   
Example:  AIRMOS.EXE -I C:\MOSAIC\AIRMOS.INI
This allows you to specify the location of the AIRMOS.INI file you want to use.    By default, 
Mosaic uses the AIRMOS.INI file found in your Windows directory.    Although it is easy to 
make changes to the Mosaic configuration, there may be some reason you want to have 
multiple configurations of Mosaic available; you you can use this option to do so.    To 
create another configuration of Mosaic, configure Mosaic the way you want it, and then 
copy the AIRMOS.INI file to a directory other than your Windows directory.    Any further 
configuration you make will affect the AIRMOS.INI file in the Windows directory; you can 
then switch to the other configuration by using the command line option, above.
 




